Creating Static Routes Using Packet Tracer

Creating Static Routes Using Packet Tracer
Photo by Kvistholt Photography / Unsplash

Using packet tracer I created the following simple network that included:

  • 3 Routers
  • 3 Pc's

I've included the topology as well in case anyone needs a look.

The following table is the IP Addressing layout for all the devices as well as the interfaces. Below the table are the configurations for each router. I've removed the unneeded portions as they pertain to this lab.

IP Address Assignment

Device Interface IP Address Default Gateway
Router 1 Gi0/0 10.41.1.1/24 *
Router 1 Serial 0/3/0 10.41.10.1/30 *
Router 2 Gi0/0 10.41.2.1/24 *
Router 2 Serial 0/2/0 10.41.10.9/30 *
Router 2 Serial 0/3/0 10.41.10.2/30 *
Router 3 Gi0/0 10.41.3.1/24 *
Router 3 Serial 0/2/0 10.41.10.10/30 *
PC1 Network Interface Card 10.41.1.10/24 10.41.1.1
PC2 Network Interface Card 10.41.2.10/24 10.41.2.1
PC3 Network Interface Card 10.41.3.10/24 10.41.3.1

Router Configurations

Router 1

Router1#show running-config 
Building configuration...

hostname Router1
!
interface GigabitEthernet0/0
 ip address 10.41.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/2/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/0
 ip address 10.41.10.1 255.255.255.252
 clock rate 64000
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.41.2.0 255.255.255.0 10.41.10.2 
!

!
end

Router 2

Router2#show running-config 
Building configuration...


hostname Router2
!
!
!
!
!
ip cef
no ipv6 ce
!
interface GigabitEthernet0/0
 ip address 10.41.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 ip address 10.41.10.9 255.255.255.252
 clock rate 2000000
!
interface Serial0/2/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/0
 ip address 10.41.10.2 255.255.255.252
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
ip route 10.41.1.0 255.255.255.0 10.41.10.1 
!
!
end

Router 3

Router3#show running-config 
hostname Router3
!
!
!
interface GigabitEthernet0/0
 ip address 10.41.3.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface Serial0/2/0
 ip address 10.41.10.10 255.255.255.252
!
interface Serial0/2/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/0
 no ip address
 clock rate 2000000
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
end

I had some issues with getting the devices working and I've documented them below.

Troubleshooting:

Issue: Devices would not connect with copper crossover cable
Resolution: Needed to add transceivers to SFP ports on routers


Issue: Was getting invalid IP and subnet errors when trying to configure interfaces on routers

Resolution: Reviewed IP subnetting and found out I was either using the broadcast or network address when configuring the x.x.x.x/30 IP addresses.


Issue: Devices would not ping default gateway
Resolution: PC’s were on different subnet with incorrect IP, once static IP set in range of addresses no issues


Issue: While testing could not ping 2 PCS
Resolution: Tested to early before all static routes were set, using packet tracer I was able to see that packet was sent but no return message could be received, finished added static routes and issue resolved.